FW and OpROM Package for Native SAS mode and Intel(R) Embedded Server RAID Technology II
 
October 21, 2006
	MPT FW v.01.16.00.00
	MPT OpROM v.06.10.00
	SAS SW RAID OpROM v.A.01.10241435I

Supported RAID modes: 0, 1, 10, and 5 (with use of Intel(r) RAID Activation Key AXXRAKSW5)

Supported Intel(R) RAID Controllers: SROMBSAS18E (native mode only - not HW RAID mode)
Supported Modules: Intel(R) S5000PAL with SAS I/O Module (native mode only)
Supported Intel(R) Server Boards and Systems: SR1500ALSAS, SR2500LX (native mode only)  
Supported Silver & Prodcution Intel(R) Server Boards and Systems: S5000PSLSAS, S5000VSASAS, S5000VCLSAS and equivalent SAS models using the S5000X chipset. SR1550AL and S5000PSLROMB are supported for native mode only. 
Silver boards must have at least B1 stepping of the SAS controller 
Supported LSI(R) RAID Adapters : See bottom of these instructions.

Note: Intel(R) Integrated Server RAID has a separate update package.

WARNING: In SAS SW RAID mode, no more than 8 drives are supported (even as spare) and only ONE expander may be used. Use of additional expanders or more than 8 drives at any time while in SW RAID mode may cause critical data failures and is specifically NOT supported. 

Upgrade Installation Instructions:
------------------------------------
1.Unzip all of the files from the zip package onto bootable DOS media (floppy, USB key, or CD), maintaining the directory structure.
Note: Only one SAS controller should be active in the system during update or be very careful to choose the correct controller to update. POST time will be improved if no other drives are attached to the server. 

2. Boot to DOS and at the prompt type in the name of the batch file that matches your board model: 
almp_upd.bat  	SR1550ALSAS,SR2500LX
albp_upd.bat  	SR1500ALSAS
aliomupd.bat  	S5000PAL based system with SAS I/O Module
lpsasupd.bat  	S5000PSLROMB, SROMBSAS18E
casasupd.bat  	S5000VCLSAS
slsasupd.bat  	S5000PSLSAS and S5000XVNSAS
sasasupd.bat  	S5000VSASAS

5. Reboot and confirm the OpROM/FW versions (depending on mode) and drives listed.


Known installation issues:
1) The update process may hang when the FW update step completes and not return the user to DOS prompt. Workaround: Reboot the server and then at a DOS prompt type:
	mptutil -o -nbdx mptsas.rom megasr.rom
The FW update is then completed. If the utility hangs exiting this phase as well, check the revisions of the OpROM and FW (from the OpROM POST display and by entering the config utility during POST) as the update process completes unless an error message is displayed. This possible hang condition is under investigation but not yet root caused.

2) On systems containing older firmware, the update may fail with an error message (including but not limited to "Device ID's don't match"). Workaround (only for test environments): Erase the older FW - which creates a non-unique SAS ID.
Workaround instructions:

1. From the DOS prompt type:
mptutil -o -e714
2. Repeat step 2 in the standard install instructions above.
3. Clear persistent settings by typing:
mptutil -o -e9
4. Reprogram to the "universal" SAS ID by typing:
mptutil -o -t 50006b0123456700
5. Reboot and check versions and drives.

Non-Intel, LSI SAS Adapters (Native SAS mode only)
------------------------------------------------
Use the appropriate directory and batch file that matches the name of your LSI adapter. 
1064 adapters: SAS3041x
1068 adapters: SAS3080x, SAS3441x, SAS3442x, SAS3800x, SAS3801x
1064e adapters: SAS3041e
1068e adapters: SAS3442e, SAS3444e, SAS3801e

1. Navigate to the root directory of the zip files (created by the user) and type:
mptutil -f [adapter name].bat
Note: If there is an onboard SCSI controller that is *not* disabled in the system, you may prompted to load/test the on-board SCSI chip. This MUST be skipped or the chip may become non-operational. Select <n> to SKIP this chip.
2. Reboot and note the SAS OpROM/FW versions and visible drives.


